Image of Cortney & Jeremy

Net Field Day – Intro and Day 1

by Jeremy L. Gaddis on September 27, 2010 · 3 comments

in Events

Unless you live under a rock, by now you know that the first Gestalt IT Net Field Day event took place in San Jose, California, on September 16th and 17th. After a couple Tech Field Day events, Greg Ferro had the idea that something similar should be held for networking nerds. Stephen Foskett, Gestalt IT’s fearless leader, put a plan into action, culminating in twelve independent bloggers descending on San Jose to meet up with seven companies in the tech industry.

Who was there?

A total of twelve delegates — independent, unbiased bloggers — attended, including myself: Ethan Banks, Brandon Carroll, Greg Ferro, Jeremy Filliben, Josh Horton, Jennifer Huber, Ivan Pepelnjak, Bob Plankers, Steven Rossen, Terry Slattery, and Jeremy Stretch.

Jeremy Stretch said “this gathering was simply epic” and I have to agree. Many of us had “met” each other virtually prior to the event but many of us were meeting for the first time in “meatspace”.

Net Field Day crew - Photo by Stephen FoskettNetworking Tech Field Day crew (l-r): Brandon Carroll, Stephen Foskett, Jeremy Stretch, Jennifer Huber, Bob Plankers, Josh Horton, Jeremy Gaddis, Jeremy Filliben, Greg Ferro, Ivan Pepelnjak, Steve Rossen, Ethan Banks, Terry Slattery

The vendor side was well represented too. The first day we met up with Hewlett-Packard, SolarWinds, CradlePoint and Force 10. The second day had us meeting with Juniper, Arista, and Xsigo.

A brief word about documentation

Before I jump right in to discussing the vendors and their presentations, I wanted to mention one thing we brought up to nearly all of them: documentation.

Anyone who has ever dealt with a Cisco product knows how is easy it is to find documentation online. Cisco has design guides, references guides, the DocCD, and much more freely available to anyone online. This is not the case with many of the other vendors. THIS MUST CHANGE. Greg has written about it (and so has Ivan) so I’ll just mention a quick example.

In January, Juniper released PSN-2010-06-623 (“JUNOS kernel cores when it receives an crafted TCP option”) but I wasn’t allowed to see it (as I’m not a Juniper paying customer). I really don’t like that (I’m a firm believer in full disclosure) so I set out to find the exact vulnerability. I found it, then posted code to the full-disclosure mailing list and even made a video showing how to exploit it. A day or two later, the PSN got posted to the web anyway, so there’s really no point in hiding them in the first place. C’mon, guys, have some sense.

Analysts

One more thing: we don’t care about analysts. We don’t care what Gartner, IDC, or any of the others say or think. We’re educated, we tend to keep up on what’s going on in the industry, and we’ll form our own opinions, thank you very much.

Anyway…

Pre-Net Field Day

While the Net Field Day events didn’t officially begin until Thursday, I arrived in San Jose on Tuesday. I headed up to San Francisco to meet up with a couple friends and had a wonderful time exploring the city, and headed back to San Jose on Wednesday. Many of us met up in the lobby of the Doubletree as we arrived, for some laid back conversation and relaxation after our flights.

Net Field Day crew - Photo by Stephen Foskett

For dinner, we headed to Spencer’s for a great meal, more “networking”, and gifts! The gifts were distributed in a token-ring type manner, with Josh Horton getting the main prize, an Apple iPad. I received a copy of Microsoft Office 2008 for Mac. I already had this (yay for being a volume license customer) — and have since upgraded to 2011 — so I traded it off to Greg for a t-shirt. Fair trade, in my opinion.

We had an early start Thursday morning, so after dinner most of us retired for the night.

Day 1

We started off Thursday by heading to HP’s Executive Briefing Center in Cupertino. Jay Mellman, whom I first met at the HP Networking Tech Day event last month, started out. He talked about HP’s acquisition of 3Com and how those products filled up some holes in HP’s networking portfolio. Most of what I heard here was a recap of the discussion at the previous HP event, but it was new to most of the delegates.

Next, we took a trip down the hallway to a “showroom” where some talking head in a suit gave us the pitch on the A12500 datacenter switches (with list prices of $13,709 and $27,429 USD for the A12508 and A12518, respectively). Unfortunately, he couldn’t answer basic technical questions and we weren’t really impressed. HP really missed a great opportunity to put an engineer in front of us who could speak to the technical details of these switches. I wasn’t the only one who thought so — Steve Rossen agrees.

Throughout HP’s session, we heard “Gartner” and “IDC” mentioned way too much (see above: “we don’t care about analysts”). Erin Collopy (@ErinatHP) caught on that we didn’t care and came through with some technical documents that she gave to us on flash drives. Thanks Erin!

Les Stuart talked to us about the Intelligent Management Center product. Les is a technical guy, being one of the software engineers who has spent years working on IMC. It was a nice change to hear from a technical guy. If you’re interested in IMC, there’s a free 60-day trial of IMC Professional available for download.

To end out the day at HP, we heard about the TippingPoint IPS products. The information presented was largely a rehash of what I’d heard at the HP Network Tech Day, albeit with much less technical detail. Regardless, I believe it was quite beneficial to the other delegates, many of whom weren’t really familiar with the TippingPoint security products (or DVlabs).

Overall, the HP presentations were alright, but not spectacular. Less marketing and analyst fluff and more technical details would’ve made the difference.

Someone may have inconspicuously left an “I LOVE JUNOS” sticker in HP’s Executive Briefing Center when no one was looking.

Disclosure: HP provided us with a 4GB USB drive (to keep) with various marketing materials.

The gang from SolarWinds — Josh Stephens (a.k.a. the “Head Geek”), Joel Dolisy, and Brandon Shopp — were up next. It was quickly obvious that these three were technical guys and they could relate to us. Their primary focus was on their key product, Orion Network Performance Monitor. They walked us their online demo and Orion’s features and capabilities. In a move that was much appreciated by the delegates, they spoke openly and honestly about Orions strengths and even — gasp! — its weaknesses. We liked the fact that they were very forthcoming and they addressed some of our questions and concerns by sharing their future plans for Orion.

They also introduced us to thwack:

thwack, SolarWinds online community site, was designed by network engineers, for network engineers. thwack is a vibrant, growing community of more than 30,000 IT pros who share a passion for technology.

Joel spoke at length and in great technical details, making full use of the available whiteboard, to provide us with a greater understanding of the application’s architecture and the database backend. I have a decent understanding of database workings, but Joel’s talk was a bit too much for me (that’s not a bad thing, by the way!).

While Orion NPM has a nice little price tag attached to it, SolarWinds does offer a number of free tools that would be beneficial to just about anyone in networking. Definitely check them out if you haven’t already.

Disclosure: my employer is a SolarWinds customer and we use Orion for monitoring our Cisco infrastructure. SolarWinds gave us a gift box which included a SolarWinds coffee mug, some stickers and buttons, and a free exam voucher for the SolarWinds Certified Professional examination. They’ve also offered to provide us with licenses to use in our labs (which I intend to take them up on). Thanks guys!

Gary Oliverio, CTO and Founder of CradlePoint, took center stage after SolarWinds. Gary gave us an overview of CradlePoint’s 3G/4G product offerings which, to me, seemed to be aimed at the consumer and SMB markets as failover devices. Many of them can take the place of, for example, your home broadband router. Connect a 3G/4G aircard (or other supported device) and the router will automatically failover to the cellular network when it detects that your broadband connection has went away. As someone who works remotely quite often, this definitely caught my attention. I can definitely see CradlePoint’s sales increasing as more people continue to telecommute.

The CradlePoint units could best be compared to Verizon’s MiFi, though packed with a lot more features that make it better suited to an SMB than the MiFi.

CradlePoint’s products are built on top of NetBSD, which is a plus in my eyes. I’m a big fan of products built on open-source, and I prefer those built on top of BSD licensed code over those built on top of Linux (and the GPL), but that’s a “religious argument” for another day.

Jennifer Huber covered some possible side effects that we may encounter if the CradlePoint devices become popular.

Before Gary’s session ended, he gave each of a CradlePoint unit to use/keep/kill with fire/whatever we wanted. While my T-Mobile BlackBerry 9700 isn’t on the list of officially supported devices, I’ve been successful in the past using it as a modem so I was confident I could make it work. After I returned home, I began playing with my new CradlePoint CTR500 and, after a quick Google search, it took me all of 10 minutes to get it configured and providing Internet access to my laptop over WPA2-encrypted WiFi. The throughput wasn’t quite what I would have hoped for (~300 kbps downstream), but that is, of course, due to the 3G signal in my neighborhood (and still plenty enough for SSH sessions!).

My primary use would be to quickly VPN into work to fix something when I was away from home/work/anywhere with WiFi. I tested it by SSH’ing over the cellular network to a FreeBSD server at home and the connection was quite good, albeit with a few hundred milliseconds of latency. The latency wasn’t a problem, however, and the CradlePoint now has a spot in my backpack along with my laptop and console and network cables. I expect it will get a fair amount of use when I’m on the road. Thanks, Gary!

Disclosure: as mentioned, I received a free CradlePoint CTR500 unit to keep.

Force 10 Networks wrapped up the presentations on Thursday. They wasted no time telling us that they didn’t even bother bringing a PowerPoint (+1 Internets). Peter grabbed the dry-erase markers and hit the whiteboard right off the bat. It was quickly apparent that Force 10 brought along a technical guy to run the show, and after being subjected to way too much marketing in the morning, we really appreciated that. They were laid back and spent as much time listening as they did talking, even if they managed to insult nearly everyone in the room at one point or another! They clearly “got it” and had the best session of the day.

Force 10 is all about the datacenter. They’ve been around for quite a while, and were one of the first to market with 10G Ethernet switches. They have quite the product lineup and they all run FTOS, the Force 10 Operating System. We immediately noticed how much the configuration resembles IOS. For example, take a look at this snippet of a config posted by Chris Jones:

!
interface TenGigabitEthernet 0/52
 description >> CORE-B
 ip address 172.20.30.130/30
 ip ospf network point-to-point
 no shutdown
!
interface Vlan 236
 ip address 172.20.236.1/24
 untagged GigabitEthernet 0/1-47
 untagged GigabitEthernet 1/1-23
 ip access-group ACL_UNTRUST_IN in
 ip helper-address 12.185.173.82
 no shutdown
!
router ospf 1
 router-id 172.20.255.128
 log-adjacency-changes
 network 172.20.0.0/16 area 0
 passive-interface default
 no passive-interface TenGigabitEthernet 0/51
 no passive-interface TenGigabitEthernet 0/52
!

Look familiar to anyone else? Yeah, me too.

Force 10 has some “quite large” customers in the datacenter space and, as Ivan put it, “I’m positive their boxes do what they promise (otherwise they would have been thrown out of those accounts long ago).”

Force 10 easily had the best presentation of the day, due to the minimal marketing and maximum tech. One of the group told them right at the beginning to “turn the nerd meter up to 11″. That’s what we wanted, and that’s what they did. Thanks, Force 10!

Day 1 wrap-up

Thursday evening, we made our way to the Computer History Museum in Mountain View which was a truly awesome experience. Immediately upon entering, we were met by a Cisco AGS router.

Cisco’s first product, the AGS router, was based on Stanford University’s multi-protocol router software and hardware. The software was written by Bill Yeager and the hardware or “Bluebox” used a processor board invented by Andreas Bachtolsheim. These routers linked Alto workstations, mainframes, LISP machines, minicomputers and printers to others in a unified network. Two members of Stanford’s computer support staff, Len Bosack and Sandy Lerner, founded Cisco systems in 1984, taking most of the Stanford design team with them.

Seeing the AGS made Ivan and Terry’s eyes light up! Ivan explained to me how it worked and how the cards connected. It was amazing to see it firsthand and hear it from Ivan.

We were also treated to a private demonstration of the Babbage Engine or, more appropriately, “Difference Engine No. 2″ which, again, was amazing.

Thursday evening at the Museum was a great opportunity for the vendors and delegates to spend some relaxing time getting to talk to each other. It was the perfect venue for networking over dinner and drinks. Afterwards, we headed back to the hotel to prepare for day 2.

{ 1 comment… read it below or add one }

Leave a Comment

{ 2 trackbacks }

Previous post:

Next post: